Ticket #381 (closed enhancement: later)

Opened 12 years ago

Last modified 12 years ago

MMC support should be compiled-in

Reported by: pavel@… Owned by: laforge@…
Priority: high Milestone:
Component: kernel Version: current svn head
Severity: minor Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

MMC support should be compiled-in (not a module), so that it is possible to boot
snapshot-of-the-day off the SD card, without flashing the fic. As everyone needs
MMC support, anyway, it does not really cost anything.

Change History

comment:1 Changed 12 years ago by laforge@…

  • Status changed from new to closed
  • Resolution set to later

I disagree. MMC support adds a couple of seconds of kernel boot delay (due to
slow mmc scanning kernel thread). We cannot afford an even slower boot. In
fact, several months ago, we had MMC/SD support in the kernel image and removed
it just for this very reason.

We will only add mmc support to the kernel once we have re-worked the mmc
stack/drivers in a way that they only scan for a card if the card_detect gpio is
set.

However, due to the architecture and the stange level of abstraction between mmc
core, s3cmci driver and platform/machine plugin, this is by far more complex
than it should be.

I just looked into this yesterday and gave up on it, since it's too time
consuming now.

Note: See TracTickets for help on using tickets.