Ticket #410 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

Needing default volumes of the various devices displayed by "alsamixer"

Reported by: tonyguan@… Owned by: laforge@…
Priority: high Milestone:
Component: kernel Version: unspecified
Severity: normal Keywords:
Cc: buglog@…, eric_liu1@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

We need a system tool to set the default volumes of the various devices
displayed by "alsamixer" so that the dialer will not suffer a noisy scream
when connected.
And I also found that this condition will occur more frequently when the phone
cover is attached.

Though adjusting by "alsamixer" can solve this problem, but the options are so
many that we can get lost there.

Perhaps a more brief *.state with the tuned voluems should be introduced?

Change History

comment:1 Changed 12 years ago by tonyguan@…

  • Cc eric_liu1@… added

* Bug 372 has been marked as a duplicate of this bug. *

comment:2 Changed 12 years ago by laforge@…

at some point we will have an audio profile daemon which you can use to switch
different scenarios (much like asound.state now).

For now, you can use the standard libasound API's for mixer control.

comment:3 Changed 11 years ago by willie_chen@…

  • Status changed from new to closed
  • Resolution set to fixed

For now, we have default scenarios in /etc/xxx.state.

Note: See TracTickets for help on using tickets.