Ticket #421 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

systray applet only shows white rectangles

Reported by: mickey@… Owned by: stefan@…
Priority: high Milestone:
Component: openmoko-panel Version: unspecified
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

The matchbox-panel-2 only shows a white rectangle for every applet that docks
into it.

Attachments

panel-startup-oe-stuff.patch (1.6 KB) - added by stefan@… 12 years ago.
openmoko-panel-startup oe infrastructure
panel-startup-oe-stuff.2.patch (2.1 KB) - added by stefan@… 12 years ago.
Fixed patch. This one inlcudes the needed bitbake recipe

Change History

comment:1 Changed 12 years ago by mallum@…

matchbox-panel-1 applets ?

comment:2 Changed 12 years ago by mickey@…

Yes. We'd like to use the matchbox-inputmanager and the matchbox-startup-monitor
together with matchbox-panel-2.

comment:3 Changed 12 years ago by mallum@…

You are probably better off rewriting them to not be system tray applets (i.e
applet modules) or at least as gtk based systray applets. Reasoning;

  • For some reason mb systray applets do not work well with gtk based systray

docks. I have tried to debug this in the past with little success - they did
work at sometime in the past. Im sure it is fixible but its probably the same
amount of work to do either of the above and this is a better solution long term.

  • The background of systray applets can only be solid color and matchbox

applets have no way of knowing what this color should be in GTK

  • Im really trying to kill off matchbox-panel-1 and libmatchbox and replace

with matchbox-panel-2/gtk. I dont really develop either anymore.

comment:4 Changed 12 years ago by mickey@…

  • Status changed from new to assigned

Ok, thanks for the comments. I guess I'll have a go at converting both applets
to matchbox-panel-2 then.

comment:5 Changed 12 years ago by stefan@…

  • Status changed from assigned to new
  • Owner changed from mallum@… to stefan@…

Short status update:

I'm working the startup-notifier applet migration right now. Input manager
follow afterwards.

comment:6 Changed 12 years ago by stefan@…

  • Status changed from new to assigned

The matchbox-panel-2 startup notifier, openmoko-panel-startup, works fine now.
It is already in svn and tested.

I already got a review from Matthew for the matchbox vanilla version. We should
be able to merge this into matchbox svn soon.

comment:7 Changed 12 years ago by stefan@…

In terms of the input manager applet.

Matthew and Ross had worked out a gtk input method which let the keyboard popup
once a textentry field is in use.

http://svn.o-hand.com/repos/matchbox/trunk/matchbox-keyboard/gtk-im/

It is pretty new and I have not tested it yet, but I will do this next week.

The only drawback I see is that we still need somekind of proxy or other visible
thing to switch between the different input methods. This brings me to the
question if we will stay with three different input methods: matchbox-keyboard,
openmoko-keyboard and stroke recognition

Changed 12 years ago by stefan@…

openmoko-panel-startup oe infrastructure

comment:8 Changed 12 years ago by stefan@…

  • attachments.isobsolete changed from 0 to 1

comment:9 Changed 12 years ago by stefan@…

  • attachments.isobsolete changed from 0 to 1

(From update of attachment 160)
Patch is in svn now

comment:10 Changed 12 years ago by stefan@…

The white rectangle is gone now due to upstream fixes.

It remains the problem with the applet for choosing input methods. I'm working
on this problem now.

comment:11 Changed 12 years ago by stefan@…

  • Status changed from assigned to closed
  • Resolution set to fixed

I just added a patch for a matchbox-keyboard to OE.dev and sent it upstream for
discussion and hopefully inclusion.

With this the white rectangle is no more needed to enable/disable the keyboard
if autopopup fails.

We still need a real Inputmethod API. But this is discussed in Bug #44

comment:12 Changed 12 years ago by mickey@…

  • Component changed from matchbox-panel-2 to openmoko-panel

changing component to openmoko-panel, component matchbox-panel-2 will be removed

Note: See TracTickets for help on using tickets.