Ticket #591 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

dialing from contacts needs to be possible without stylus

Reported by: pavel@… Owned by: thomas@…
Priority: high Milestone:
Component: openmoko-contacts Version: unspecified
Severity: normal Keywords:
Cc: buglog@…, elrond+bugzilla.openmoko.org@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Currently, contacts are impossible to control without stylus. That's bad, almost
all calls happen from contacts. It should be possible to at least select a
contact and call it using fingers, only.

Change History

comment:1 Changed 12 years ago by thomas@…

In the design (http://wiki.openmoko.org/wiki/Contacts), contacts is a purely
stylus application. However, the design currently doesn't actually specify how
to make calls from the contacts list, although the design for the phone number
fields specifies a popup menu with a dial option:
http://wiki.openmoko.org/wiki/Phone_Number_Field.

comment:2 Changed 12 years ago by elrond+bugzilla.openmoko.org@…

  • Cc elrond+bugzilla.openmoko.org@… added

Well, this could also be a dedicated new Design (even App).

Just showing the contacts and a few options what to do.
The font should be large enough to make it easy to read the names while running
down the stairs to catch your train. ;)

So this probably should be some sort of finger application.

Personal note: I find the finger wheel not too useful. So for paging through the
contacts-finger-app, I'd appreciate some dedicated big "page down" and "page up"
buttons or the like.

comment:3 Changed 12 years ago by thomas@…

I absolutely agree and I will see if I can bring this up with the core team
again. Last time it was discussed there was a sense that because we were
targeting OpenMoko? as a platform rather than a phone, the contacts application
(and others) should be stylus based. However, I wonder if there is also room for
simplified finger versions of all the core applications as well, which would be
used in just the sort of situation you describe.

comment:4 Changed 12 years ago by stefan@…

  • Status changed from new to closed
  • Resolution set to fixed

This is possible in OM2007.2

Note: See TracTickets for help on using tickets.