Ticket #599 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

pulseaudio compilation fails

Reported by: ruediger@… Owned by: mickey@…
Priority: high Milestone:
Component: OE bitbake recipes / build system Version: current svn head
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

during make openmoko-devel-image, the pulseaudio compilation install step fails
with this error:

/opt/openmoko/build/tmp/work/i486-linux/pulseaudio-0.9.6-r1/temp/run.do_install.16372:
line 701: do_install: command not found

Attachments

log.do_install.29374 (127 bytes) - added by ruediger@… 12 years ago.
do_install log
run.do_install.29374 (21.7 KB) - added by ruediger@… 12 years ago.
do_install script
pulseaudio_targetfpu.patch (397 bytes) - added by ken@… 12 years ago.
Removes offending line from pulseaudio BitBake?-File
pulseaudio_targetfpu_fix_and_cleanup.patch (758 bytes) - added by ken@… 12 years ago.
Fix Pulseaudio Bitbake compilation + minor cleanup

Change History

Changed 12 years ago by ruediger@…

do_install log

Changed 12 years ago by ruediger@…

do_install script

Changed 12 years ago by ken@…

Removes offending line from pulseaudio BitBake?-File

comment:1 Changed 12 years ago by stefan@…

  • Component changed from openmoko-dates to OE bitbake recipes / build system

It builds fine for me with svnrev 2205, without the suggested modification,
here. Can you please retry with this revision?

comment:2 Changed 12 years ago by stefan@…

  • Owner changed from thomas@… to mickey@…

comment:3 Changed 12 years ago by freyther@…

pulseaudio.0.9.6.bb is trying to export TARGET_FPU by using the same variable
name in assignement.

How is that related to the error with do_install? Could you please exlain it?

comment:4 Changed 12 years ago by mickey@…

this is a recursive assignment. does using the := operator fix it?

comment:5 Changed 12 years ago by ruediger@…

The problem only occours with MACHINE = "x86" set, not MACHINE = "fic-gta01".
Maybe therefore the error related to the TARGET_FPU variable.

Changed 12 years ago by ken@…

Fix Pulseaudio Bitbake compilation + minor cleanup

comment:6 Changed 12 years ago by ken@…

The TARGET_FPU variable gets exported to the shell but on x86 it is an empty
string. The statement is therefore not needed.

comment:7 Changed 12 years ago by developer@…

I had to add TARGET_FPU="" to .conf as suggested in one of the build
instructions to get pulseaudio to build with MACHINE="x86" tonight on my gentoo
laptop using MokoMakefile? which in theory is pulling down the latest SVN.

comment:8 Changed 12 years ago by stefan@…

Can anybody with this problem verify that this still happens with OM2007.2,
which is based on the newest OE.dev tree? Mokomakefile already builds the new
one after an update.

I ask beacuse I'm not able to reproduce this problem on my x86 or x86_64 machine
and also can not find a bugreport about such a problem in the OpenEmbedded?
bugzilla although pulseaudio is used in different images.

comment:9 Changed 11 years ago by mickey@…

  • Status changed from new to closed
  • Resolution set to fixed

Closing this for now. Feel free to reopen if still a problem.

Note: See TracTickets for help on using tickets.