Ticket #739 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

svnREV missing from uImage

Reported by: elrond+bugzilla.openmoko.org@… Owned by: mickey@…
Priority: high Milestone:
Component: OE bitbake recipes / build system Version: 2007.2
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

As can be seen on the official buildhost, the uImage does not any longer include
the svn revision (patch set), that was used to build them.
This makes useful bugreports on kernel issues harder, because people can't
easily say, what revision they used for testing.

Current: http://buildhost.openmoko.org/OM2007.2/tmp/deploy/glibc/images/fic-gta01/

The old build system did have this:
http://buildhost.openmoko.org/OM2007.1/tmp/deploy/images/

Change History

comment:1 Changed 12 years ago by stefan@…

We can use this again once the bitbake 1.8.8 and the SRCREV feature are
mandatory for the OE metadata. This will happen 2007-09-04.

comment:2 Changed 12 years ago by stefan@…

We have two different uboot recipes in OE now. One using a pinned svn and git
rev which gets displayed in the filename. This is the default recipe.

The other one pulls bleeding edge git revs and our newest patches in and tries
to build it. This one now shows the rev for our svn but only the date for the
git rev. It's not possible to use the git rev in the filename in this way atm.

comment:3 Changed 11 years ago by mickey@…

  • Status changed from new to closed
  • Resolution set to fixed

fixed a while ago.

Note: See TracTickets for help on using tickets.