Ticket #747 (closed defect: fixed)

Opened 12 years ago

Last modified 21 months ago

uicmoc4-native_4.3.1.bb

Reported by: yoyo@… Owned by: mickey@…
Priority: high Milestone:
Component: OE bitbake recipes / build system Version: current svn head
Severity: normal Keywords:
Cc: buglog@…, matt.mets@…, technil@…, zmedico@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

during compilation in dependency is qtopia-core and it crash :/
starts .....
.....
emb-x86_64/cppwriteicondeclaration.o
.obj/release-static-emb-x86_64/cppwriteiconinitialization.o
.obj/release-static-emb-x86_64/cppwriteincludes.o
.obj/release-static-emb-x86_64/cppwriteinitialization.o
.obj/release-static-emb-x86_64/main.o .obj/release-static-emb-x86_64/ui3reader.o
.obj/release-static-emb-x86_64/parser.o .obj/release-static-emb-x86_64/domtool.o
.obj/release-static-emb-x86_64/object.o
.obj/release-static-emb-x86_64/subclassing.o
.obj/release-static-emb-x86_64/form.o .obj/release-static-emb-x86_64/converter.o
.obj/release-static-emb-x86_64/widgetinfo.o
.obj/release-static-emb-x86_64/embed.o .obj/release-static-emb-x86_64/qt3to4.o
.obj/release-static-emb-x86_64/deps.o
-L/home/moko/build/tmp/work/x86_64-linux/uicmoc4-native-4.3.1-r0/qtopia-core-opensource-src-4.3.1/lib
-lQt3Support
-L/home/moko/build/tmp/work/x86_64-linux/uicmoc4-native-4.3.1-r0/qtopia-core-opensource-src-4.3.1/lib
-lQtSql -lQtNetwork -lssl -lcrypto -lQtXml -lQtGui -lQtCore -lz -lm -lrt -ldl
-lpthread
|
/home/moko/build/tmp/work/x86_64-linux/uicmoc4-native-4.3.1-r0/qtopia-core-opensource-src-4.3.1/lib/libQtGui.a(qapplication_qws.o):
In function `QWSDisplay::Data::~Data()':
| qapplication_qws.cpp:(.text+0x4ac7): undefined reference to
`QAbstractSocket::flush()'
|
/home/moko/build/tmp/work/x86_64-linux/uicmoc4-native-4.3.1-r0/qtopia-core-opensource-src-4.3.1/lib/libQtGui.a(qapplication_qws.o):
In function `QWSDisplay::Data::~Data()':
| qapplication_qws.cpp:(.text+0x4dd7): undefined reference to
`QAbstractSocket::flush()'
|
/home/moko/build/tmp/work/x86_64-linux/uicmoc4-native-4.3.1-r0/qtopia-core-opensource-src-4.3.1/lib/libQtGui.a(qapplication_qws.o):
In function `QWSDisplay::Data::waitForQCopResponse()':
| qapplication_qws.cpp:(.text+0x5942): undefined reference to
`QAbstractSocket::flush()'
|
/home/moko/build/tmp/work/x86_64-linux/uicmoc4-native-4.3.1-r0/qtopia-core-opensource-src-4.3.1/lib/libQtGui.a(qapplication_qws.o):
In function `QWSDisplay::Data::waitForCreation()':
| qapplication_qws.cpp:(.text+0x5a05): undefined reference to
`QAbstractSocket::flush()'
|
/home/moko/build/tmp/work/x86_64-linux/uicmoc4-native-4.3.1-r0/qtopia-core-opensource-src-4.3.1/lib/libQtGui.a(qapplication_qws.o):
In function `QWSDisplay::Data::waitForConnection()':
| qapplication_qws.cpp:(.text+0x5a69): undefined reference to
`QAbstractSocket::flush()'
|
/home/moko/build/tmp/work/x86_64-linux/uicmoc4-native-4.3.1-r0/qtopia-core-opensource-src-
......

Attachments

fix-undefined-reference.patch (252 bytes) - added by matt.mets@… 12 years ago.
fixes 'undefined reference' errors during compilation caused by the network library not being included correctly
uicmoc4-native_4.3.1.bb.patch (457 bytes) - added by zmedico@… 12 years ago.
patch uicmoc4-native_4.3.1.bb to add QT += network in uic3.pro

Change History

comment:1 Changed 12 years ago by roh@…

  • Owner changed from davewu01@… to mickey@…
  • Component changed from Graphics Design to OE bitbake recipes / build system

comment:2 Changed 12 years ago by matt.mets@…

* Bug 753 has been marked as a duplicate of this bug. *

comment:3 Changed 12 years ago by matt.mets@…

* Bug 754 has been marked as a duplicate of this bug. *

comment:4 Changed 12 years ago by matt.mets@…

  • Cc matt.mets@… added

comment:5 Changed 12 years ago by matt.mets@…

I am seeing the same issue on an x86_64 system running Gentoo, with gcc 3.4.6

I don't know enough about qtopia to diagnose this well, however the missing
references all seem to be in the library lQtNetwork, which is not included when
this file is built. Adding it manually (copying the g++ command to a terminal)
causes a different set of undefined references (starting with `ASN1_STRING_data').

qtopia-core-opensource-src-4.3.1 builds fine on its own on my system as a
dynamic library (after I apply a workaround for an incompatibility with gcc
3.4.6), so the issue seems to be either with the way it is set up in the build
system or the specific target (embedded, static) being built.

The line that seems to be causing the issue for me is as follows:
| g++ -Wl,-rpath,/moko/build/tmp/staging/x86_64-linux/qt4/lib
-Wl,-rpath,/moko/build/tmp/staging/x86_64-linux/qt4/lib -o screenshot
.obj/release-static-emb-x86_64/main.o
.obj/release-static-emb-x86_64/screenshot.o
.obj/release-static-emb-x86_64/moc_screenshot.o
-L/moko/build/tmp/work/x86_64-linux/uicmoc4-native-4.3.1-r0/qtopia-core-opensource-src-4.3.1/lib
-lQtGui
-L/moko/build/tmp/work/x86_64-linux/uicmoc4-native-4.3.1-r0/qtopia-core-opensource-src-4.3.1/lib
-lQtCore -lz -lm -lrt -ldl -lpthread

comment:6 Changed 12 years ago by technil@…

  • Cc technil@… added

Same package failing here while building openmoko-devel-image.

NOTE: Tasks Summary: Attempted 1036 tasks of which 72 didn't need to be rerun
and 1 failed.
ERROR:
'/media/usbdisk/moko/openembedded/packages/uicmoc/uicmoc4-native_4.3.1.bb' failed
make: * [openmoko-devel-image] Error 1

Processor: x86 Intel Core Duo

GCC:

technil@automata:/media/usbdisk/moko/build/tmp/work/i686-linux/uicmoc4-native-4.3.1-r0/temp$
gcc -v
Reading specs from /usr/lib/gcc/i486-linux-gnu/3.4.6/specs
Configured with: ../src/configure -v --enable-languages=c,c++,f77,pascal
--prefix=/usr --libexecdir=/usr/lib --with-gxx-include-dir=/usr/include/c++/3.4
--enable-shared --with-system-zlib --enable-nls --without-included-gettext
--program-suffix=-3.4 --enable-cxa_atexit --enable-clocale=gnu
--enable-libstdcxx-debug --with-tune=pentium4 i486-linux-gnu
Thread model: posix
gcc version 3.4.6 (Ubuntu 3.4.6-3ubuntu1)

when looking in:

moko/build/tmp/work/i686-linux/uicmoc4-native-4.3.1-r0/temp/log.do_compile.2139

problem seems to start here in the log:

ccache gcc -c -isystem/media/usbdisk/moko/build/tmp/staging/i686-linux/include
-Os -fno-exceptions -O2 -fvisibility=hidden -Wall -W -D_REENTRANT
-DQT_BUILD_GUI_LIB -DQT_NO_CAST_TO_ASCII -DQT_ASCII_CAST_WARNINGS -DQT3_SUPPORT
-DQT_MOC_COMPAT -DQT_NO_IMAGEFORMAT_PNG -DQT_RASTER_IMAGEENGINE
-DQT_RASTER_PAINTENGINE -DQT_HAVE_MMX -DQT_HAVE_3DNOW -DQT_HAVE_SSE
-DQT_HAVE_MMXEXT -DQT_HAVE_SSE2 -DQT_NO_FONTCONFIG -DQT_NO_STYLE_MAC
-DQT_NO_STYLE_WINDOWSVISTA -DQT_NO_STYLE_WINDOWSXP -DQ_INTERNAL_QAPP_SRC
-DQT_NO_DEBUG -DQT_CORE_LIB -D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE
-I../../mkspecs/qws/linux-x86-g++ -I. -I../../include/QtCore
-I../../include/QtCore -I../../include -I../../include/QtGui
-I/usr/include/freetype2 -I../3rdparty/harfbuzz/src -Idialogs
-I../../include/QtNetwork -I.moc/release-static-emb-x86
-I.uic/release-static-emb-x86 -o .obj/release-static-emb-x86/qblackraster.o
painting/qblackraster.c
cc1: error: unrecognized command line option "-fvisibility=hidden"
make[1]: * [.obj/release-static-emb-x86/qblackraster.o] Error 1
make[1]:
* Waiting for unfinished jobs....
make[1]: Leaving directory
`/media/usbdisk/moko/build/tmp/work/i686-linux/uicmoc4-native-4.3.1-r0/qtopia-core-opensource-src-4.3.1/src/gui'
FATAL: oe_runmake failed

for me the offending option was: -fvisibility=hidden

It appears in the GCC 4.2.1 manual http://gcc.gnu.org/onlinedocs/gcc-4.2.1/gcc.pdf
But not in the GCC 3.4.6 manual
http://gcc.gnu.org/onlinedocs/gcc-3.4.6/gcc.pdf

From the GCC 4.2.1 Manual:
"
-fvisibility=default|internal|hidden|protected

Set the default ELF image symbol visibility to the specified option—all

symbols will be marked with this unless overridden within the code. Using this
feature can very substantially improve linking and load times of shared object
libraries, produce more optimized code, provide near-perfect API export and
prevent symbol clashes. It is strongly recommended that you use this in any
shared objects you distribute. Despite the nomenclature, default always means
public ie; available to be linked against from outside the shared object.
protected and internal are pretty useless in real-world usage so the only other
commonly used option will be hidden. The default if ‘-fvisibility’ isn’t
specified is default, i.e., make every symbol public—this causes the same
behavior as previous versions of GCC."

they suggest looking at:

http://gcc.gnu.org/wiki/Visibility.

I am reading it, but it is still over my head. maybe GCC 3.4.6 chokes on the
-fvisibility=hidden flag (not defined) and we just need to install a newer GCC?

comment:7 Changed 12 years ago by matt.mets@…

adding the line:
QT += network
to examples/desktop/screenshot/screenshot.pro allowed me to get through my first
error, unfortunately the build failed with the same error on the next example
program being built.

technil, I think you might be having a different issue, the error you reported
doesn't seem to match this one. My apologies if I mislead you by steering you here.

comment:8 Changed 12 years ago by openmoko@…

I had the same problem but after upgrading to gcc 4.2 it works fine for me....

comment:9 Changed 12 years ago by eric@…

I had same problem on i686 using gcc 3.4.6 and x86_64 gcc 4.1.2
Adding +network to the uic3.pro file changes the order of the libraries in the
link line from

-lQtNetwork -lssl -lcrypto -lQtXml -lQtGui

to

-lQtXml -lQtGui -lQtNetwork -lssl -lcrypto

which worked on both platforms

Changed 12 years ago by matt.mets@…

fixes 'undefined reference' errors during compilation caused by the network library not being included correctly

comment:10 Changed 12 years ago by technil@…

Although this is not specifically the same bug, I am just posting that using a
newer (GCC >/= 4.1) overcomes the -fvisibility=hidden "unrecognized command line
option" problem I detailed above for uicmoc4-native_4.3.1.bb Sorry for the
noise. At this point I consider my problem solved.

comment:11 Changed 12 years ago by yoyo@…

the attachment file (id=260) works fine

comment:12 Changed 12 years ago by zmedico@…

  • Cc zmedico@… added

Changed 12 years ago by zmedico@…

patch uicmoc4-native_4.3.1.bb to add QT += network in uic3.pro

comment:13 Changed 12 years ago by sudharsh@…

hi,
the patch to add QT+= network in uic3.pro (attachment id 310), solves the
problems. Confirmed on gentoo with gcc 4.2.0 and 4.1.2

comment:14 Changed 12 years ago by developer@…

Bug is still present from fresh MokoMakefile? build on an amd64 system this
evening running gentoo and gcc 4.1.2. I can confirm patch #310 resolves
uicmoc4-native not building for me, too.

comment:15 Changed 12 years ago by graeme@…

  • Status changed from new to closed
  • Resolution set to fixed

Should be fixed in OE revision 1d2da7c2a64cb6782d396f30259020ad4254cf69 thanks
for the patch.

comment:16 Changed 2 years ago by Kennescoma

Cialis Shop Bewertung <a href=http://zol1.xyz/how-to-buy-zoloft.php>How To Buy Zoloft</a> Is Pharmacy Rx One Legitimate buy accutane generic <a href=http://zol1.xyz/cheapest-zoloft.php>Cheapest Zoloft</a> Levitra Bayern Kamagra Paypal <a href=http://cial5mg.xyz/buying-cialis-online.php>Buying Cialis Online</a> Cialis Medicamento Efectos Secundarios Dr Anil Pande Viagra <a href=http://viagra.ccrpdc.com/viagra-samples.php>Viagra Samples</a> Viagra Online Preisvergleich Need Fluoxetine Mastercard Accepted Medication Free Shipping <a href=http://kama1.xyz/cheapest-kamagra.php>Cheapest Kamagra</a> Acheter Du Cialis 10mg Comprar Levitra En Andorra <a href=http://cial1.xyz/tadalafil-online.php>Tadalafil Online</a> Levothyroxine Tablets To Buy Generika Viagra Shop <a href=http://cial5mg.xyz/map.php>Shop Cialis Online</a> Propecia Efectividad Buy Propecia Hair Loss <a href=http://viag1.xyz/viagra-cheap-online.php>Viagra Cheap Online</a> Viagra And Cialas For Aale Tamoxifen Citrate <a href=http://kamagra.ccrpdc.com/kamagra-pill.php>Kamagra Pill</a> Were To Buy Levothyroxine

comment:17 Changed 22 months ago by Abrahammaime

cialis online dove comprarlo

<a href="http://cialisgsaa.com/">buy cialis online</a>

everyday cialis side effects

<a href=http://cialisgsaa.com/>cheap cialis</a>

comment:18 Changed 21 months ago by RalphCleks

tomar cialis y micardis

<a href="http://buycialisgenericbsl.com/">buy cialis online</a>

cialis drug side effects

<a href=http://buycialisgenericbsl.com/>buy cialis online</a>

Note: See TracTickets for help on using tickets.