Ticket #749 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

OpenMoko will not boot without /etc/pointercal present

Reported by: openmoko@… Owned by: mickey@…
Priority: high Milestone:
Component: neod Version: 2007.2
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

If /etc/pointercal is not present then the calibration program is meant to be
run on boot.

If I remove /etc/pointercal and reboot, OpenMoko? hangs at the "Please wait while
starting UI" screen.

I have seen this when using a build where the pointercal package has been
excluded and also after booting OpenMoko?, running rm /etc/pointercal in the
terminal and rebooting.

NOTE: I do not possess a Neo 1973 and so have only observed this with qemu.

Change History

comment:1 Changed 12 years ago by mickey@…

I can't reproduce this on a Neo, so this seems to be a Qemu-only thing.

comment:2 Changed 11 years ago by mickey@…

still a problem?

comment:3 Changed 11 years ago by openmoko@…

  • Status changed from new to closed
  • Resolution set to fixed

Using a local build of OpenMoko? that I built this morning this appears to be fixed.

I removed /etc/pointercal and rebooted the qemu device. It ran the touchscreen
calibration program and then continued to boot fine, which strikes me as the
desired behaviour.

Note: See TracTickets for help on using tickets.