Ticket #757 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

Patch to openmoko-dialer to handle CREG: 2 responses

Reported by: rod@… Owned by: thomas@…
Priority: high Milestone:
Component: openmoko-dialer Version: 2007.2
Severity: normal Keywords:
Cc: buglog@…, dpavlin@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

It seems that registration on my cellular provider's network takes more than 5
seconds.

This patch allows openmoko-dialer to properly handle a
MOKO_GSMD_CONNECTION_NETREG_SEARCHING event from the libmokogsmd2 library, and
wait for registration to complete, instead of continually retrying the
registration request and thereby causing the phone *never* to register.

The patch is at http://pastebin.ca/672064

Basically, I replace the boolean reg_request and registered private variables
with a new version of the registered private variable of type
MokoGsmdConnectionNetregType?. This allows the code in register_network_cb to
handle the different cases of NONE, SEARCHING, DENIED, and HOME/ROAMING.

Attachments

openmoko-dialer.patch (3.8 KB) - added by thomas@… 12 years ago.
Patch from Rod Whitby

Change History

comment:1 Changed 12 years ago by rod@…

* Bug 755 has been marked as a duplicate of this bug. *

comment:2 Changed 12 years ago by rod@…

  • Cc dpavlin@… added

comment:3 Changed 12 years ago by rod@…

  • bug_file_loc changed from http://pastebin.ca/672064 to http://svn.nslu2-linux.org/svnroot/mokomakefile/trunk/patches/openmoko-HEAD/openmoko-dialer.patch

Changed 12 years ago by thomas@…

Patch from Rod Whitby

comment:4 Changed 12 years ago by njp@…

  • Status changed from new to closed
  • Resolution set to fixed

Hmm, I did amend that function to work properly when 'Searching' was returned.
However, your approach is cleaner and reads better, so I've applied the patch in
svn, thanks!

Note: See TracTickets for help on using tickets.