Ticket #783 (closed defect: duplicate)

Opened 12 years ago

Last modified 11 years ago

usb networking mac address changes on each boot

Reported by: rod@… Owned by: willie_chen@…
Priority: high Milestone:
Component: kernel Version: 2007.2
Severity: normal Keywords:
Cc: buglog@…, cw@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

To connect two Neo's to the same host via usb networking, you need to give them
separate subnets (or at least separate IPs on the same subnet). To do this
deterministically, you need to know the MAC address of the Neo. Unfortunately,
that seems to change randomly on each boot.

Change History

comment:1 Changed 12 years ago by rod@…

Looks like it should be possible on the kernel cmdline:

module_param(dev_addr, charp, S_IRUGO);
MODULE_PARM_DESC(dev_addr, "Device Ethernet Address");
module_param(host_addr, charp, S_IRUGO);
MODULE_PARM_DESC(host_addr, "Host Ethernet Address");

(yet to be tested, will close this bug if it works)

-- Rod

comment:2 Changed 12 years ago by laforge@…

We are aware of that issue, and are planning to have fixed, official MAC
addresses allocated for the usb networking interface for GTA02.

comment:3 Changed 12 years ago by cw@…

  • Cc cw@… added

comment:4 Changed 11 years ago by willie_chen@…

  • Owner changed from laforge@… to michael@…

comment:5 Changed 11 years ago by willie_chen@…

  • Owner changed from michael@… to willie_chen@…

comment:6 Changed 11 years ago by werner@…

  • Status changed from new to closed
  • Resolution set to duplicate

This is in fact a close relative to #1023. So the same work-around
applies, and also the long-term solution is the same.

* This bug has been marked as a duplicate of 1023 *

Note: See TracTickets for help on using tickets.