Ticket #837 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

Lack of / small icons in list of running tasks

Reported by: hrw@… Owned by: chris@…
Priority: high Milestone:
Component: openmoko-today Version: current svn head
Severity: normal Keywords:
Cc: buglog@…, emreturkay@…, chris@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

3rd tab in Today show list of running tasks with icons. But for most of apps
it show default one instead of application icon.

Change History

comment:1 Changed 12 years ago by chris@…

  • Cc chris@… added

This is because it gets the icon from the window manager - It should probably
fall-back (or possibly use by default?) the icon from a matched .desktop file.

comment:2 Changed 12 years ago by hrw@…

* Bug 820 has been marked as a duplicate of this bug. *

comment:3 Changed 12 years ago by thomas@…

Can we determine why it doesn't get an icon from the window manager?

comment:4 Changed 12 years ago by thomas@…

  • Owner changed from thomas@… to chris@…

comment:5 Changed 12 years ago by mickey@…

Any update on that?

comment:6 Changed 12 years ago by chris@…

  • Summary changed from Lack of icons in list of running tasks to Lack of / small icons in list of running tasks

I've been concentrating on other things, but I can prioritise this if it's
important.

comment:7 Changed 12 years ago by chris@…

* Bug 838 has been marked as a duplicate of this bug. *

comment:8 Changed 11 years ago by chris@…

  • Cc emreturkay@… added

comment:9 Changed 11 years ago by chris@…

* Bug 969 has been marked as a duplicate of this bug. *

comment:10 Changed 11 years ago by chris@…

  • Status changed from new to closed
  • Resolution set to fixed

Icon size is fixed in r3607.

In the case where there isn't an icon, it's because the applications aren't
setting window icons - this needs to be fixed for each individual application.

If we want to match a running application to its launcher file, we need to set a
custom window property so that we can match (for example, the argv[0] of the
application would do) - but again, this is something that needs to be fixed for
each individual application first.

Note: See TracTickets for help on using tickets.