Ticket #910 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

When a kernel ipkg is released, "ipkg upgrade" breaks kernel modules

Reported by: gnu@… Owned by: graeme@…
Priority: high Milestone:
Component: OE bitbake recipes / build system Version: 2007.2
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Ipkg can't upgrade a kernel (it sits in its own partition), but it can upgrade
kernel modules (which are in the normal filesystem). So when somebody releases
a new kernel and modules, the new modules get loaded by "ipkg upgrade" and then
they don't work with the old kernel.

I flashed the 2007.2 release, then after getting my USB networking gatewayed
properly, did "ipkg update && ipkg upgrade". This installed new kernel modules
(and maybe tried to install a new kernel into the ordinary filesystem). This
broke my kernel modules (e.g. mounting vfat filesystems didn't work; the sound
stopped playing at reboot; etc) until I was able to figure out where to find the
new kernel and manually flash it into the kernel partition.

How to fix this? An obvious way would be to make the kernel ipkg install the
new kernel into the kernel's proper partition. Failing that, it may be possible
to circumvent the problem by administratively never releasing new incompatible
modules into a repository where "ipkg update" will install them for ordinary
naive users.

Change History

comment:1 Changed 12 years ago by laforge@…

  • Owner changed from laforge@… to graeme@…
  • Component changed from kernel to OE bitbake recipes / build system

this is actually a bug of the OE / bitbake recipe, since the ipkg should utilize
something like mtd-tools to write the kernel image to the kernel partition after
installing a new kernel ipkg.

comment:2 Changed 12 years ago by graeme@…

We are investigating the infrastructure to fix this in the right way. I have a
feeling a normal ipkg upgrade on a mobile device shouldn't touch the kernel.
Just in case something goes wrong and the person is hours/days away from their
own machine where they can fix their phone.

comment:3 Changed 12 years ago by graeme@…

I now have a kernel-image that will upgrade the kernel partition, not sure what
to do about first boot.

comment:4 Changed 11 years ago by graeme@…

  • Status changed from new to closed
  • Resolution set to fixed

Changes committed to OE

Note: See TracTickets for help on using tickets.