Ticket #927 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

Application list not updated when new applications are installed

Reported by: thomas@… Owned by: chris@…
Priority: high Milestone:
Component: openmoko-today Version: current svn head
Severity: normal Keywords:
Cc: buglog@…, emreturkay@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

The application browser is not updated when new applications are installed.

Change History

comment:1 Changed 12 years ago by thomas@…

  • Owner changed from thomas@… to chris@…

comment:2 Changed 11 years ago by mickey@…

Application Manager should issue a dbus call that makes Today reload all the
.desktop files.

comment:3 Changed 11 years ago by chris@…

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in r3283 using the code from matchbox-desktop2, which uses inotify.

comment:4 Changed 11 years ago by thomas@…

  • Cc emreturkay@… added

* Bug 1053 has been marked as a duplicate of this bug. *

comment:5 Changed 11 years ago by thomas@…

* Bug 1053 has been marked as a duplicate of this bug. *

comment:6 Changed 11 years ago by chris@…

  • Status changed from closed to reopened
  • Resolution fixed deleted

Although this works fine on the desktop, it would appear inotify isn't working
on the neo? :/

Would be good if someone that knows a bit more about inotify could comment on this.

comment:7 Changed 11 years ago by emreturkay@…

To duplicate the problem:

Create a test_bug.desktop in /usr/share/applications and fill it in as

cat > test_bug.desktop

[Desktop Entry]
Encoding=UTF-8
Name=test-bug
Exec=/usr/bin/ls
Icon=applications-games
Terminal=false
Type=Application
Categories=Game
StartupNotify?=true
SingleInstance?=true
Comment=To test the bug.

Save it.
Open the application browser.
It's not there, and there is no way to load it.

comment:8 Changed 11 years ago by chris@…

  • dependson set to 1139

Opened new bug about broken inotify, marked as dependency.

comment:9 Changed 11 years ago by chris@…

  • Status changed from reopened to closed
  • Resolution set to fixed

Fixed upstream in libtaku, updated and tested to work in r3893.

Note: See TracTickets for help on using tickets.