Ticket #940 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

Dialer cursor positioning is confusing

Reported by: igorfoox@… Owned by: thomas@…
Priority: high Milestone:
Component: openmoko-dialer Version: 2007.2
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

When in the Dialer application clicking on the number text field positions an
invisible cursor. If the cursor is placed in the middle of the number, then
entering new digits or erasing seems to erase only what's left to the cursor.
Since there is no visual indication of the cursor the user thinks that the
portion of the number to the right of the cursor is now *stuck* there because he
can't erase it.

Possible solutions:

  • Make the cursor visible
  • Remove the cursor

I think the first option is much more reasonable.

Change History

comment:1 Changed 12 years ago by alphaone@…

Actually the digit before the cursor position is shown in bold, but that is not
updated if position it somewhere in the number. If you then delete/add a digit
the correct position is indicated.
I say we just continue to use that indication and update the entry field when
the cusor moves.

comment:2 Changed 12 years ago by igorfoox@…

If the highlighting works when repositioning the cursor, that might help the
user understand that there is a cursor. However, we really need to try this out
with people, because in my experience showing the phone to people the most
common reaction was: "Why is the last digit fat?", and these were usually
tech-savvy people.

In my opinion having the selected digit be bold is not a good indicator of a
cursor because people just don't expect it. Usually a cursor is a vertical line
between characters such as "76232|1834" or a underline type thing that you see
in the terminal.

comment:3 Changed 12 years ago by alphaone@…

In my opinion having a cursor would disturb the general appearance. We should
definitely hide the cursor when it is at the last position.

comment:4 Changed 12 years ago by thomas@…

I don't know of any reason why the last digit should be bold, other than it was
that was in the very original mockups:
http://wiki.openmoko.org/wiki/Dialer#Dial_Mode

comment:5 Changed 11 years ago by mickey@…

Since we have derived so much from the original design anyway, I don't mind
getting rid of the cursor.

comment:6 Changed 11 years ago by thomas@…

  • Status changed from new to closed
  • Resolution set to fixed

I've removed the cursor indicator and made sure all input is now added to the
end of the display.

Note: See TracTickets for help on using tickets.