Ticket #945 (closed defect: worksforme)

Opened 12 years ago

Last modified 2 years ago

moko-gtk-engine throws errors

Reported by: koen@… Owned by: thomas@…
Priority: high Milestone:
Component: Theming - Gtk+ Version: current svn head
Severity: normal Keywords:
Cc: buglog@…, thomas@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

/usr/share/themes/Moko/gtk-2.0/gtkrc:162: Invalid symbolic color 'fg_color'
/usr/share/themes/Moko/gtk-2.0/gtkrc:162: error: invalid identifier `fg_color',
expected valid identifier

Change History

comment:1 Changed 12 years ago by koen@…

  • Cc thomas@… added

comment:2 Changed 12 years ago by thomas@…

Strange, the same symbollic colour name is used just a few lines up. What SVN
revision produces those errors?

comment:3 Changed 12 years ago by koen@…

root@a780:~# ipkg list_installed | grep moko-g
moko-gtk-engine - 0.1.0+svnr3207-r0 - Moko GTK+ theme engine
moko-gtk-theme - 0.1.0+svnr3207-r0 - Moko GTK+ theme engine

comment:4 Changed 12 years ago by thomas@…

I've just tested the same revisions on the device and cannot reproduce. Is there
any specific application that creates these errors?

comment:5 Changed 12 years ago by koen@…

it appears in the console after starting xserver-nodm-init by hand

comment:6 Changed 12 years ago by koen@…

The startup log (minus the config-parser messages):

ot@a780:~# /etc/init.d/xserver-nodm start
root@a780:~# Starting Xserver

Extended Input Devices not yet supported. Impelement it at line 637 in kinput.c
D-BUS per-session daemon address is:
unix:abstract=/tmp/dbus-Vc2kSYtrZM,guid=ddbeda083c37dc1cf83d3c0047163756
[settings daemon] Forking. run with -n to prevent fork
matchbox-keyboard-ui.c:150,update_display_size() mark
matchbox-keyboard-ui.c:168,update_display_size() #### Orientation know '1'

matchbox-keyboard-key.c:127,mb_kbd_key_set_fill() mark
matchbox-keyboard-key.c:127,mb_kbd_key_set_fill() mark
matchbox-keyboard-key.c:127,mb_kbd_key_set_fill() mark
matchbox-keyboard-key.c:127,mb_kbd_key_set_fill() mark
matchbox-keyboard-key.c:127,mb_kbd_key_set_fill() mark
matchbox-keyboard-key.c:127,mb_kbd_key_set_fill() mark
matchbox-keyboard-key.c:127,mb_kbd_key_set_fill() mark
matchbox-keyboard-key.c:127,mb_kbd_key_set_fill() mark
matchbox-keyboard-key.c:127,mb_kbd_key_set_fill() mark
sh: /usr/local/arm/2.95.3/bin/cpp: No such file or directory
root@a780:~# matchbox-keyboard-ui.c:722,mb_kbd_ui_resources_create() setting no
focus hint
(neod:3380): DEBUG: '/dev/input/event0' open OK, fd = '5'
(neod:3380): DEBUG: '/dev/input/event1' open OK, fd = '6'
(neod:3380): DEBUG: '/dev/input/event2' open OK, fd = '7'
(neod:3380): DEBUG: '/dev/input/event3' open OK, fd = '8'
(neod:3380): DEBUG: opened 4 input nodes.
(neod:3380): DEBUG: added fd 5 to list of watchers
(neod:3380): DEBUG: added fd 6 to list of watchers
(neod:3380): DEBUG: added fd 7 to list of watchers
(neod:3380): DEBUG: added fd 8 to list of watchers
(neod:3380): DEBUG: mainmenu powersave reset
(neod:3380): DEBUG: mainmenu powersave reset
(neod:3380): DEBUG: requested to set display brightness 100
matchbox-keyboard-remote.c:34,mb_kbd_remote_process_xevents() got a message

(neod:3380): DEBUG: backlight_node_dir = ezx-bl
(neod:3380): DEBUG: detected backlight in sysfs as
'/sys/class/backlight/ezx-bl/brightness'
(neod:3380): DEBUG: scanned maximum brightness for
'/sys/class/backlight/ezx-bl/brightness' = '50'
(neod:3380): DEBUG: writing '50' to '/sys/class/backlight/ezx-bl/brightness'
(neod:3380): DEBUG: panel mainmenu sound init
(neod:3380): DEBUG: mainmenu sound state callback. state = 1
(neod:3380): DEBUG: sound init ok. threaded mainloop started
(neod:3380): DEBUG: mainmenu sound state callback. state = 2
(neod:3380): DEBUG: mainmenu sound state callback. state = 3
(neod:3380): DEBUG: mainmenu sound state callback. state = 4
/usr/share/themes/Moko/gtk-2.0/gtkrc:162: Invalid symbolic color 'fg_color'
/usr/share/themes/Moko/gtk-2.0/gtkrc:162: error: invalid identifier `fg_color',
expected valid identifier
matchbox-keyboard-remote.c:34,mb_kbd_remote_process_xevents() got a message

matchbox-keyboard-remote.c:34,mb_kbd_remote_process_xevents() got a message

matchbox-keyboard-remote.c:34,mb_kbd_remote_process_xevents() got a message

matchbox-keyboard-remote.c:39,mb_kbd_remote_process_xevents() is a Client Message

(matchbox-panel-2:3385): DEBUG: moko_panel_applet_init
(matchbox-panel-2:3385): DEBUG: moko_panel_applet_init
libmokogsmd: Unable to connect to gsmd, trying to start it
/usr/share/themes/Moko/gtk-2.0/gtkrc:162: Invalid symbolic color 'fg_color'
/usr/share/themes/Moko/gtk-2.0/gtkrc:162: error: invalid identifier `fg_color',
expected valid identifier
/usr/share/themes/Moko/gtk-2.0/gtkrc:162: Invalid symbolic color 'fg_color'
/usr/share/themes/Moko/gtk-2.0/gtkrc:162: error: invalid identifier `fg_color',
expected valid identifier
Stopping GSM daemon: no /usr/sbin/gsmd found; none killed.
gsmd.
Starting GSM daemon: gsmd.

(matchbox-panel-2:3385): WARNING : libgsmd: can't connect to gsmd. You
won't receive any events.
(matchbox-panel-2:3385): DEBUG: moko_panel_applet_init
Got path /org/gnome/evolution/dataserver/calendar/filehome_rootmoko_journal_
for new calendar

(openmoko-today:3382): WARNING : Cannot read
/usr/share/today/vfolders/PIM.directory: No such file or directory
(neod:3380): DEBUG: mainmenu powersave timeout 1
(neod:3380): DEBUG: requested to set display brightness 25
(neod:3380): DEBUG: writing '12' to '/sys/class/backlight/ezx-bl/brightness'
matchbox-keyboard-remote.c:34,mb_kbd_remote_process_xevents() got a message

matchbox-keyboard-remote.c:34,mb_kbd_remote_process_xevents() got a message

matchbox-keyboard-remote.c:34,mb_kbd_remote_process_xevents() got a message

matchbox-keyboard-remote.c:34,mb_kbd_remote_process_xevents() got a message

matchbox-keyboard-remote.c:34,mb_kbd_remote_process_xevents() got a message

matchbox-keyboard-remote.c:34,mb_kbd_remote_process_xevents() got a message

matchbox-keyboard-remote.c:34,mb_kbd_remote_process_xevents() got a message

matchbox-keyboard-remote.c:34,mb_kbd_remote_process_xevents() got a message

Got path /org/gnome/evolution/dataserver/calendar/filehome_rootmoko_journal_
for new calendar
(openmoko-dialer:3383): DEBUG: Journal Loaded
Got path
/org/gnome/evolution/dataserver/calendar/filehome_rootevolution_calendar_local_system_
for new calendar
Got path
/org/gnome/evolution/dataserver/calendar/filehome_rootevolution_tasks_local_system_
for new calendar
(openmoko-dialer:3383): DEBUG: The Journal is empty
(neod:3380): DEBUG: mainmenu powersave timeout 2
(neod:3380): DEBUG: requested to set display brightness 0
(neod:3380): DEBUG: writing '0' to '/sys/class/backlight/ezx-bl/brightness'
(openmoko-dialer:3383): DEBUG: Requesting registration

comment:7 Changed 12 years ago by koen@…

root@a780:/usr/share/themes/Moko/gtk-2.0# grep fg_color *
gtkrc:gtk_color_scheme =
"fg_color:#333;bg_color:#ccc;base_color:#ccc;text_color:#000;selected_bg_color:#ff7d00;selected_fg_color:#000"
gtkrc: fg [NORMAL] = @fg_color
gtkrc: fg [PRELIGHT] = @fg_color
gtkrc: fg [ACTIVE] = @selected_fg_color
gtkrc: fg [INSENSITIVE] = @fg_color
gtkrc: fg [SELECTED] = @selected_fg_color
gtkrc: bg[NORMAL] = @fg_color
gtkrc: bg[PRELIGHT] = @fg_color
gtkrc: text[NORMAL] = @selected_fg_color
gtkrc: text[PRELIGHT] = @selected_fg_color
gtkrc: fg[NORMAL] = @selected_fg_color
gtkrc: bg[PRELIGHT] = @fg_color
gtkrc: bg[ACTIVE] = @fg_color
gtkrc: fg[NORMAL] = @selected_fg_color
gtkrc: fg[PRELIGHT] = @selected_fg_color
openmoko-calculator: bg[NORMAL] = @selected_fg_color
openmoko-dialer: bg[NORMAL] = @selected_fg_color
openmoko-dialer: base[NORMAL] = @selected_fg_color
openmoko-dialer: fg[NORMAL] = @fg_color
openmoko-dialer: bg[PRELIGHT] = @selected_fg_color
root@a780:/usr/share/themes/Moko/gtk-2.0#

comment:8 Changed 12 years ago by hrw@…

root@fic-gta01Bv4:~/$ ipkg list_installed | grep moko-g
moko-gtk-engine - 0.1.0+svnr3240-r0 - Moko GTK+ theme engine
moko-gtk-theme - 0.1.0+svnr3240-r0 - Moko GTK+ theme engine

I have same problem:
/usr/share/themes/Moko/gtk-2.0/gtkrc:65: Invalid symbolic color 'fg_color'
/usr/share/themes/Moko/gtk-2.0/gtkrc:65: error: invalid identifier `fg_color',
expected valid identifier
/usr/share/themes/Moko/gtk-2.0/gtkrc:65: Invalid symbolic color 'fg_color'
/usr/share/themes/Moko/gtk-2.0/gtkrc:65: error: invalid identifier `fg_color',
expected valid identifier

comment:9 Changed 12 years ago by thomas@…

Can you check to make sure the gtkrc file was installed properly? I still
haven't been able to reproduce this reliably.

comment:10 Changed 11 years ago by nod_huang@…

  • Owner changed from buglog@… to thomas@…

comment:11 Changed 11 years ago by thomas@…

  • Status changed from new to closed
  • Resolution set to worksforme

Resolving as WORKSFORME since I can't reproduce and no further information has
been given.

comment:12 Changed 2 years ago by RoberMync

Kamagra Deutschland Forum <a href=http://zithromax.ccrpdc.com/generic-for-zithromax.php>Generic For Zithromax</a> Acheter Priligy Sans Ordonnance Macrobid Mail Order <a href=http://kama1.xyz/kamagra-online-buy.php>Kamagra Online Buy</a> Buying Generic Levitra Clavulanate Potassium And Penicillin <a href=http://cial1.xyz/prices-cialis.php>Prices Cialis</a> Cytotec Acheter Ligne Propecia Depression Acne <a href=http://viag1.xyz/sildenafil-citrate.php>Sildenafil Citrate</a> Kamagras Online Australia Amoxicillin And Cetalopram <a href=http://viag1.xyz/cost-of-viagra.php>Cost Of Viagra</a> Viagra 100mg 12 Stck Cialis Et Forum <a href=http://zol1.xyz/zoloft-generic.php>Zoloft Generic</a> Propecia En Productos De Farmacia Ciprofloxacin Functional Groups <a href=http://kama1.xyz/buy-kamagra-usa.php>Buy Kamagra Usa</a> Cialis 10 Mg Opinioni Cialis 5mg Prix Pharmacie <a href=http://cial1.xyz/how-to-order-cialis.php>How To Order Cialis</a> Propecia From China Achat Propecia En Ligne <a href=http://kama1.xyz/buy-generic-kamagra-online.php>Buy Generic Kamagra Online</a> Propecia En Medicamentos Where To Purchase Generic Amoxicilina Quick Shipping <a href=http://zoloft.ccrpdc.com/buy-generic-zoloft.php>Buy Generic Zoloft</a> Macrobid 100mg On Sale Stromectol 3mg <a href=http://kama1.xyz/cheap-kamagra-no-rx.php>Cheap Kamagra No Rx</a> Zithromax Rhinopharyngite Vente Cialis Authentique <a href=http://zol1.xyz/shop-zoloft-online.php>Shop Zoloft Online</a> Suhagra 100 Free Shipping Buy Cheap Kamagra Online <a href=http://viag1.xyz/order-viagra-onlines.php>Order Viagra Onlines</a> Zestril Lisinopril 4 Sale Generic Viagra From India <a href=http://cial5mg.xyz/cheap-cialis-online.php>Cheap Cialis Online</a> Cialis Effet Secondaire Levitra Comparaison Zithromax Off Patent <a href=http://cial1.xyz/how-to-buy-cialis.php>How To Buy Cialis</a> Finasteride 1 Mg Buy Uk Lasix For Dog Without Prescription <a href=http://viag1.xyz/cheap-viagra-on-line.php>Cheap Viagra On Line</a> Acquisto Kamagra 100mg Le Viagra Homme <a href=http://strattera.ccrpdc.com/buy-atomoxetine-online-india.php>Buy Atomoxetine Online India</a> Cialis Pas Chere Kamagra Consegna Veloce <a href=http://cial1.xyz/brand-cialis-online.php>Brand Cialis Online</a> Secure Zentel Valtrex Overnight Delivery <a href=http://kama1.xyz/buy-kamagra-oral-jelly.php>Buy Kamagra Oral Jelly</a> Viagra Y Diabetes Cephalexin For Dental <a href=http://viag1.xyz/china-viagra-online.php>China Viagra Online</a> Is Cephalexin Harmful To Dogs Levitra 20 Mg Vardenafil <a href=http://zol1.xyz/buy-zoloft-online-usa.php>Buy Zoloft Online Usa</a> Canadain Drugs Kamagra Rezeptfrei <a href=http://cytotec.ccrpdc.com/cytotec-misoprostol.php>Cytotec Misoprostol</a> Dutasteride In Internet Anaheim Levitra 10 Mg Basf <a href=http://cial1.xyz/cost-of-cialis.php>Cost Of Cialis</a> No Pain Tooth Infection And Amoxicillin Acheter Generique Levitra <a href=http://kama1.xyz/cheap-kamagra-pills.php>Cheap Kamagra Pills</a> Kamagra Information

Note: See TracTickets for help on using tickets.