Ticket #954 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

MokoMakefile does not build image files even after successful packages compilation

Reported by: bugslayer@… Owned by: rod@…
Priority: high Milestone:
Component: MokoMakefile Version: current svn head
Severity: major Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

MokoMakefile? does not build image files even after successful packages compilation

repro:

  1. make update-makefile && make setup update openmoko-devel-image
  2. make qemu-local

what's wrong:
make openmoko-devel-image does not generate image files, even when I see such
text as "NOTE: build 200710222253: completed", so make qemu cannot continue -
the truth is, it fails with the following output:

[ -e build/qemu ]

( mkdir -p build/qemu )

[ -e build/qemu/Makefile ]

( . ./setup-env && cd build/qemu && \

${OMDIR}/openmoko/trunk/src/host/qemu-neo1973/configure \

--target-list=arm-softmmu )

[ -e build/qemu/openmoko ]

( . ./setup-env && cd build/qemu && mkdir openmoko && \

for f in ${OMDIR}/openmoko/trunk/src/host/qemu-neo1973/openmoko/* ; do

\

ln -s $f openmoko/basename $f ; \

done )

ln -sf pwd/openmoko/trunk/src/host/qemu-neo1973/openmoko/env build/qemu/openmo
ko/env

[ -d stamps ]
mkdir stamps

touch stamps/qemu
( cd build/qemu && make )
make[1]: Entering directory `/home/openmoko/om/build/qemu'
make -C arm-softmmu all
make[2]: Entering directory `/home/openmoko/om/build/qemu/arm-softmmu'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/openmoko/om/build/qemu/arm-softmmu'
make[1]: Leaving directory `/home/openmoko/om/build/qemu'
( cd build && . ../setup-env && \

bitbake openmoko-devel-image uboot-openmoko )

NOTE: Psyco JIT Compiler (http://psyco.sf.net) not available. Install it to incr
ease performance.
NOTE: Handling BitBake? files: / (4772/4772) [100 %]
NOTE: Parsing finished. 4542 cached, 0 parsed, 230 skipped, 0 masked.
NOTE: build 200710222302: started

OE Build Configuration:
BB_VERSION = "1.8.8"
OE_REVISION = "7f97df68d9bbb4bbdb3287edf727a04a5a29c6a8"
TARGET_ARCH = "arm"
TARGET_OS = "linux-gnueabi"
MACHINE = "fic-gta01"
DISTRO = "openmoko"
DISTRO_VERSION = "P1-Snapshot-20071022"
TARGET_FPU = "soft"

NOTE: Resolving missing task queue dependencies
NOTE: preferred version 2.5 of glibc not available (for item virtual/arm-angstro
m-linux-gnueabi-libc-for-gcc)
NOTE: multiple providers are available for virtual/libqte2 (qte-mt-static, qte,
qte-mt);
NOTE: consider defining PREFERRED_PROVIDER_virtual/libqte2
NOTE: Preparing runqueue
NOTE: Executing runqueue
NOTE: Running task 4958 of 4959 (ID: 4, /home/openmoko/om/openembedded/packages/
images/openmoko-devel-image.bb, do_rootfs)
NOTE: package openmoko-devel-image-1.0: started
NOTE: package openmoko-devel-image-1.0-r0: task do_rootfs: started
NOTE: package openmoko-devel-image-1.0-r0: task do_rootfs: completed
NOTE: package openmoko-devel-image-1.0: completed
NOTE: Running task 4959 of 4959 (ID: 5, /home/openmoko/om/openembedded/packages/
images/openmoko-devel-image.bb, do_build)
NOTE: package openmoko-devel-image-1.0: started
NOTE: package openmoko-devel-image-1.0-r0: task do_build: started
NOTE: package openmoko-devel-image-1.0-r0: task do_build: completed
NOTE: package openmoko-devel-image-1.0: completed
NOTE: Tasks Summary: Attempted 4959 tasks of which 4957 didn't need to be rerun
and 0 failed.
NOTE: build 200710222302: completed

[ -d stamps ]
mkdir stamps

touch stamps/openmoko-devel-image
( cd build/qemu && openmoko/flash.sh ../tmp/deploy/glibc/images/fic-gta01 )
/usr/bin/gmake
which: no gecho in (/opt/kde3/bin:/usr/java/jdk1.6.0_03/bin:/home/po/bin:/usr/lo
cal/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib/jvm/jre/bi
n:/usr/lib/mit/bin:/usr/lib/mit/sbin:/usr/lib/qt3/bin)
openmoko/flash.sh: line 27: cd: ../tmp/deploy/glibc/images/fic-gta01: No such fi
le or directory
/usr/bin/pngtopnm
/usr/bin/ppmtorgb3
gmake[1]: Entering directory `/home/openmoko/om/build/qemu/openmoko'
gmake[1]: `splash.gz' is up to date.
gmake[1]: Leaving directory `/home/openmoko/om/build/qemu/openmoko'
ls: cannot access /home/openmoko/om/build/qemu/uImage-2.6.*-fic-gta01.bin: No su
ch file or directory
basename: missing operand
Try `basename --help' for more information.
ls: cannot access /home/openmoko/om/build/qemu/OpenMoko*.rootfs.jffs2: No such f
ile or directory
basename: missing operand
Try `basename --help' for more information.
ls: cannot access /home/openmoko/om/build/qemu/u-boot-gta01b*.bin: No such file
or directory
basename: missing operand
Try `basename --help' for more information.
Using as the kernel image.
Using
as the root filesystem image.
Using as bootloader.
gmake[1]: Entering directory `/home/openmoko/om/build/qemu/openmoko'
# Making an empty/erased flash image. Need a correct echo behavior.
echo -en
0377
0377
0377
0377
0377
0377
0377
0377 > .8b
cat .8b .8b > .16b # OOB is 16 bytes
cat .16b .16b .16b .16b .16b .16b .16b .16b > .512b
cat .16b .16b .16b .16b .16b .16b .16b .16b >> .512b
cat .16b .16b .16b .16b .16b .16b .16b .16b >> .512b
cat .16b .16b .16b .16b .16b .16b .16b .16b >> .512b
cat .512b .16b > .sec # A sector is 512 bytes of data + OOB
cat .sec .sec .sec .sec .sec .sec .sec .sec > .8sec
cat .8sec .8sec .8sec .8sec .8sec .8sec .8sec .8sec > .64sec
cat .64sec .64sec .64sec .64sec .64sec .64sec .64sec .64sec > .512sec
cat .512sec .512sec .512sec .512sec > .2ksec
cat .2ksec .2ksec .2ksec .2ksec .2ksec .2ksec .2ksec .2ksec > .16ksec
# Neo NAND is 128k sectors big
cat .16ksec .16ksec .16ksec .16ksec .16ksec .16ksec .16ksec .16ksec > openmoko-f
lash.base
rm -rf .8b .16b .512b .sec .8sec .64sec .512sec .2ksec .16ksec
gmake[1]: Leaving directory `/home/openmoko/om/build/qemu/openmoko'
Please wait, programming the NAND flash...
sleep: invalid time interval `setenv'
sleep: invalid time interval `dontask'
sleep: invalid time interval `y'
sleep: invalid time interval `nand'
sleep: invalid time interval `createbbt'
sleep: invalid time interval `setenv'
sleep: invalid time interval `bootcmd'
sleep: invalid time interval `\'setenv'
sleep: invalid time interval `bootargs'
sleep: invalid time interval `${bootargs_base}'
sleep: invalid time interval `${mtdparts};'
sleep: invalid time interval `bootm'
sleep: invalid time interval `0x31000000\

sleep: invalid time interval `setenv'
sleep: invalid time interval `menu_1'
sleep: invalid time interval `\'Set'
sleep: invalid time interval `console'
sleep: invalid time interval `to'
sleep: invalid time interval `USB:'
sleep: invalid time interval `setenv'
sleep: invalid time interval `stdin'
sleep: invalid time interval `usbtty;'
sleep: invalid time interval `setenv'
sleep: invalid time interval `stdout'
sleep: invalid time interval `usbtty;'
sleep: invalid time interval `setenv'
sleep: invalid time interval `stderr'
sleep: invalid time interval `usbtty\
sleep: invalid time interval `setenv'
sleep: invalid time interval `menu_2'
sleep: invalid time interval `\'Set'
sleep: invalid time interval `console'
sleep: invalid time interval `to'
sleep: invalid time interval `serial:'
sleep: invalid time interval `setenv'
sleep: invalid time interval `stdin'
sleep: invalid time interval `serial;'
sleep: invalid time interval `setenv'
sleep: invalid time interval `stdout'
sleep: invalid time interval `serial;'
sleep: invalid time interval `setenv'
sleep: invalid time interval `stderr'
sleep: invalid time interval `serial\

sleep: invalid time interval `setenv'
sleep: invalid time interval `menu_3'
sleep: invalid time interval `\'Power'
sleep: invalid time interval `off:'
sleep: invalid time interval `neo1973'
sleep: invalid time interval `power-off\
sleep: invalid time interval `setenv'
sleep: invalid time interval `splashimage'
sleep: invalid time interval `\'nand'
sleep: invalid time interval `read.e'
sleep: invalid time interval `splash'
sleep: invalid time interval `0x5000;'
sleep: invalid time interval `unzip'
sleep: invalid time interval `0x96000\

sleep: invalid time interval `setenv'
sleep: invalid time interval `mtdids'
sleep: invalid time interval `nand0=neo1973-nand'
sleep: invalid time interval `setenv'
sleep: invalid time interval `mtdparts'
sleep: invalid time interval `mtdparts=neo1973-nand:0x00050000(u-boot),0x0000400
0(u-boot_env),0x00208000(kernel),0x00010000(splash),0x039a4000(rootfs)'
sleep: invalid time interval `#dynpart'
sleep: invalid time interval `nand'
sleep: invalid time interval `write.e'
sleep: invalid time interval `u-boot'
sleep: invalid time interval `dynenv'
sleep: invalid time interval `set'
sleep: invalid time interval `u-boot_env'
sleep: invalid time interval `saveenv'
Try `sleep --help' for more information.
openmoko/flash.sh: line 88: 26418 Terminated $qemu -mtdblock "$scri

pt_dir/$flash_base" -kernel

"$script_dir/$1" -serial stdio -nographic -usb -moni

tor null 0<&0

U-boot failed to finish writing in setenv dontask y nand createbbt setenv bootcm

d 'setenv bootargs

${bootargs_base} ${mtdparts}; bootm 0x31000000' setenv menu_1

'Set console to USB: setenv stdin usbtty;

setenv stdout usbtty; setenv stderr u

sbtty' setenv menu_2 'Set console to serial: setenv stdin serial;

setenv stdout serial;
setenv stderr serial' setenv menu_3 'Power off: neo1973 power-off' seten

v splashimage 'nand read.e

0x36000000 splash 0x5000; unzip 0x36000000 0x33d00000

0x96000' setenv mtdids nand0=neo1973-nand setenv

mtdparts mtdparts=neo1973-nand

:0x00050000(u-boot),0x00004000(u-boot_env),0x00208000(kernel),0x00010000(splash)

,0x039a4000(rootfs) #dynpart

nand write.e 0x31000000 u-boot 0x1000 dynenv set u-

boot_env saveenv seconds, giving up.

make: * [flash-qemu-local] Error 255

how should it be:
make openmoko-devel-image should generate image files, so make qemu-local can
exit with success.

additional info:

  1. OS: opensuse 10.3
  2. local.conf file:

MACHINE = "fic-gta01"
DISTRO = "openmoko"
BUILD_ARCH = "i686"
INHERIT += "rm_work"
PARALLEL_MAKE = "-j 4"
BB_NUMBER_THREADS = "4"
GLIBC_GENERATE_LOCALES = "en_US.UTF-8 pl_PL.UTF-8"

  1. No additional issues observed. Some time ago everytning worked fine on the

same configuration.

Change History

comment:1 Changed 12 years ago by m.bitter@…

I've had the same problem on debian.
After correcting the path in MokoMakefile? (line 421)
to "../tmp/deploy/glibc/images/neo1973" the fash.sh find the correct images
from make openmoko-devel-image but after that I have the same problem as
reportet in Bug 937:

my output from make flash-qemu-local is now:

( cd build/qemu && openmoko/flash.sh ../tmp/deploy/glibc/images/neo1973 )
/usr/bin/pngtopnm
/usr/bin/ppmtorgb3
make[1]: Entering directory `/home/openmoko/build/qemu/openmoko'
make[1]: »splash.gz« ist bereits aktualisiert.
make[1]: Leaving directory `/home/openmoko/build/qemu/openmoko'
ls: /home/openmoko/build/tmp/deploy/glibc/images/neo1973/uImage-2.6.*-fic-gta01.bin:
Datei oder Verzeichnis nicht gefunden
basename: fehlender Operand
„basename --help“ gibt weitere Informationen.
Using as the kernel image.
Using 'OpenMoko?-openmoko-devel-image-glibc-ipk-P1-Snapshot-20071027-fic-gta01.rootfs.jffs2'
as the root filesystem image.
Using 'u-boot-gta01bv4-1.2.0+gitf34024d4a328e6edd906456da98d2c537155c4f7+svn2943-r1.bin'
as bootloader.
make[1]: Entering directory `/home/openmoko/build/qemu/openmoko'
# Making an empty/erased flash image. Need a correct echo behavior.
echo -en
0377
0377
0377
0377
0377
0377
0377
0377 > .8b
cat .8b .8b > .16b # OOB is 16 bytes
cat .16b .16b .16b .16b .16b .16b .16b .16b > .512b
cat .16b .16b .16b .16b .16b .16b .16b .16b >> .512b
cat .16b .16b .16b .16b .16b .16b .16b .16b >> .512b
cat .16b .16b .16b .16b .16b .16b .16b .16b >> .512b
cat .512b .16b > .sec # A sector is 512 bytes of data + OOB
cat .sec .sec .sec .sec .sec .sec .sec .sec > .8sec
cat .8sec .8sec .8sec .8sec .8sec .8sec .8sec .8sec > .64sec
cat .64sec .64sec .64sec .64sec .64sec .64sec .64sec .64sec > .512sec
cat .512sec .512sec .512sec .512sec > .2ksec
cat .2ksec .2ksec .2ksec .2ksec .2ksec .2ksec .2ksec .2ksec > .16ksec
# Neo NAND is 128k sectors big
cat .16ksec .16ksec .16ksec .16ksec .16ksec .16ksec .16ksec .16ksec >
openmoko-flash.base
rm -rf .8b .16b .512b .sec .8sec .64sec .512sec .2ksec .16ksec
make[1]: Leaving directory `/home/openmoko/build/qemu/openmoko'
Please wait, programming the NAND flash...
300
neo_gsm_switch: GSM disabled.

U-Boot 1.3.0-rc11.2.0+gitf34024d4a328e6edd906456da98d2c537155c4f7+svn2943 (Oct
27 2007 - 14:50:08)

DRAM: 128 MB
NAND: Bad block table not found for chip 0
Bad block table not found for chip 0
64 MiB
* Warning - bad CRC or NAND, using default environment

Video: 640x480x8 31kHz 59Hz
USB: S3C2410 USB Deviced
mtdparts variable not set, see 'help mtdparts'
mtdparts variable not set, see 'help mtdparts'
mtdparts variable not set, see 'help mtdparts'
mtdparts variable not set, see 'help mtdparts'
mtdparts variable not set, see 'help mtdparts'
In: serial
Out: serial
Err: serial
pcf_write: charging in Qualification Mode.
pcf_write: charge voltage 4.20V.
neo_lcd_rst_switch: LCD reset.
jbt6k74_command: Display on.
neo_vib_switch: Buzz, buzz.
neo_vib_switch: Vibrator stopped.
neo_bl_switch: LCD Backlight now on.
GTA01Bv4 #
GTA01Bv4 #
GTA01Bv4 # setenv dontask y
GTA01Bv4 # nand createbbt
Create BBT and erase everything ? <y/N>
Skipping bad block at 0x03ff0000
Skipping bad block at 0x03ff4000
Skipping bad block at 0x03ff8000
Skipping bad block at 0x03ffc000

Creating BBT. Please wait ...Bad block table not found for chip 0
Bad block table not found for chip 0
Bad block table written to 0x03ffc000, version 0x01
Bad block table written to 0x03ff8000, version 0x01

GTA01Bv4 # setenv bootcmd 'openmoko/flash.sh: line 89: 15285 Beendet
$qemu -mtdblock "$script_dir/$flash_base" -kernel "$script_dir/$1" -serial
stdio -nographic -usb -monitor null 0<&0

U-boot failed to finish writing in 300 seconds, giving up.

make: * [flash-qemu-local] Fehler 255

comment:2 Changed 12 years ago by bugslayer@…

After changing path to images in line 421, I have the very similar output as in
#1. Please note, that still it looks like MokoMakefile? bug (missing image, bad
path etc.), what can be observed in lines:

ls: cannot access
/home/openmoko/om/build/tmp/deploy/glibc/images/neo1973/uImage-2.6.*-fic-gta01.bin:
No such file or directory
basename: missing operand
Try `basename --help' for more information.
Using as the kernel image.

comment:3 Changed 12 years ago by toni@…

i also had to change in ~/moko/build/qemu/openmoko/env

kernel_wildcard="uImage-2.6.*-fic-gta01.bin"

to

kernel_wildcard="uImage-2.6.*-neo1973.bin"

after that flash.sh hangs with the prompt

GTA01Bv4 # setenv bootcmd '

as mentioned in the wiki

http://wiki.openmoko.org/wiki/Talk:OpenMoko_under_QEMU

seems this is another bug, sorry but i could find the corresponding bug-id.

toni

comment:4 Changed 11 years ago by mickey@…

  • Component changed from autobuilds to MokoMakefile

Fixing component.

comment:5 Changed 11 years ago by mickey@…

  • Owner changed from mickey@… to rod@…

Fixing component.

comment:6 Changed 11 years ago by rod@…

  • Status changed from new to closed
  • Resolution set to fixed

Mickey fixed the env file.

Note: See TracTickets for help on using tickets.