Ticket #958 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

GSM modem dead

Reported by: rishi_date@… Owned by: tick@…
Priority: high Milestone:
Component: GSM Modem Version: GTA01v4
Severity: critical Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Bug details-

I have created customized application which is very similar to openmoko-dialer2.
I'm using functions provided in libmokogsmd library.
Application works fine with only one problem.
Problem is, If No calls are made from the phone or no incoming calls are
received for say around 5 minutes then modem goes dead, and the application
exits; while we trial to dial out a call. Also, application fails to recognize
the incoming calls in this state.

I have referred to #788 description and found in comment 23 that the kernel
is going to be updated with the resolution of the “modem dead” problem.

Details of the kernel and rootfs I am currently using -
Kernel: uImage-2.6.21.6-moko11-r2-fic-gta01.bin
Rootfs: OpenMoko?-openmoko-devel-image-glibc-P1-August-Snapshot-20070825-fic-
gta01.rootfs.jffs2

Can you please help me identifying the kernel and rootfs version with the above
problem resolved.

Thanks and Regards,
Rishikesh

Change History

comment:1 Changed 11 years ago by jserv@…

  • Owner changed from sean_chiang@… to tick@…

comment:2 Changed 11 years ago by balrogg@…

I'm afraid this is not what that comment to #788 is saying. The kernel is
going to be updated with a resolution of the "whole system dead" problem, rather
than "modem dead". The "modem dead" problem is the same problem already
described in other bugreports and is believed to be a gsmd timing issue
(although I'm now convinced that the issue is in the kernel or in the hardware
rather than in gsmd).

comment:3 Changed 11 years ago by tick@…

  • Status changed from new to assigned

comment:4 Changed 11 years ago by mickey@…

I think this has been fixed since in gsmd. Can you retry with a current build?

comment:5 Changed 11 years ago by mickey@…

Tick, is the Moko5 firmware supposed to fix this? With Moko4, I can see the
modem still refusing to answer after a while.

comment:6 Changed 11 years ago by tick@…

Mickey, I have some questions.

  1. Which gsmd SVN version your using? -- This issue should be solved after R3308.
  2. Is the gsmd refused to work for about 3 seconds or not response at all? -- If it delayed for 3 seconds, it's normal. Because wakeup scheme

transformed by a 3 seconds timeout
scheme.

-- If it does not response at all, please give me the gsmd log. Thanks.

  1. Which kernel uImage in your Neo device? (When was the Image built. ) -- We had noticed that there is a strange phenomenon that the kernel image

after 2007 Nov 6 on build host will makes Moko5 unable to sleep. It will shorten
the stand by time of Neo.

comment:7 Changed 11 years ago by rishi_date@…

We tried uaing the follwing images

Kernel image
URL: http://buildhost.openmoko.org/OM2007.2/tmp/deploy/glibc/images/neo1973/
Name: uImage-2.6.22.5-moko11+svnr3238-r8-neo1973.bin

Rootfs image
URL: http://buildhost.automated.it/OM2007.2/?M=D
Name: OpenMoko?-openmoko-devel-image-glibc-ipk-P1-Snapshot-20071118-fic-
gta01.rootfs.jffs2

The problem with gsmd seems to be resolved with the combination of the above-
mentioned kernel and the root-fs images.

One observation on this build is that the range indicator doesn’t change state
even after the phone catches range.

Here we have used the SVN R3238 for the kernel. We have not been able to
locate the R3308 revision of the kernel. Please let us know the location for
downloading the latest kernel and root-fs?

Thanks,
Rishikesh

comment:8 Changed 11 years ago by mickey@…

I think someone should measure whether there is any activity on the gsm modem
chip. It may as well be a kernel problem, but we won't know for sure until
someone starts measuring. Since there are no component placements nor specs
released, FIC Mobility needs to do this.

comment:9 Changed 11 years ago by mickey@…

Ever since starting to operate the modem in MUXing mode, I could no longer see
this behaviour. I'm tempted to close it as FIXED, if no one objects.

comment:10 Changed 11 years ago by tick

  • Status changed from assigned to closed
  • Resolution set to fixed

switch this to fixed, and close it as Mickey suggested.

Note: See TracTickets for help on using tickets.