Ticket #972 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

[patch] neod - PowerButton kills "Home"

Reported by: kristian@… Owned by: mickey@…
Priority: high Milestone:
Component: neod Version: unspecified
Severity: normal Keywords:
Cc: buglog@…, thomas@…, hrw@…, abraxa@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

As "Today" is now named "Home" the power button can close it - and X with it...

Attachments

neod_doesnt_kill_home.patch (548 bytes) - added by kristian@… 11 years ago.
patch so that neod doesnt kill home anymore
dont_kill_desktop_windows.patch (1.7 KB) - added by kristian@… 11 years ago.
neod dont_kill_desktop_windows.patch

Change History

comment:1 Changed 11 years ago by mickey@…

Thanks for the patch, however it doesn't solve the problem. The title of the
today application will vary a lot depending on the network, i.e.:

  • No Service
  • Emergency Only
  • <Operator Name>
  • Today

We need to find another charateristic to depend whether we can close it or not.
To mind come either checking whether it is the desktop window, or by setting a
"magic" X property neod would look for. Thoughts?

comment:2 Changed 11 years ago by kristian@…

Right, checking for desktop window mode would be the best way, I think.

An other idea would be to use the sticky window (show on all virtual desktops)
option so that other apps can prevent themselves from beeing killed.
(maybe a dialog is needed anyway before closing the app....)

We also have the option to check for the PID and then look up the executables
filename...

comment:3 Changed 11 years ago by mickey@…

  • Cc hrw@… added

comment:4 Changed 11 years ago by mickey@…

* Bug 979 has been marked as a duplicate of this bug. *

Changed 11 years ago by kristian@…

patch so that neod doesnt kill home anymore

comment:5 Changed 11 years ago by kristian@…

  • attachments.isobsolete changed from 0 to 1

comment:6 Changed 11 years ago by abraxa@…

  • Cc abraxa@… added

* Bug 989 has been marked as a duplicate of this bug. *

comment:7 Changed 11 years ago by mickey@…

  • Status changed from new to closed
  • Resolution set to fixed

Commited in r3347 - thanks!

comment:8 Changed 11 years ago by thomas@…

  • Status changed from closed to reopened
  • Resolution fixed deleted

It seems there has been a regression and this issue is now present again in the
latest software.

comment:9 Changed 11 years ago by mickey@…

I can't reproduce this.

comment:10 Changed 11 years ago by mickey@…

  • Cc thomas@… added

Hmm, this bugzilla sucks. If someone reopens a bug, he should be cc'ed.

Thomas, is this fixed for you?

comment:11 Changed 11 years ago by mickey@…

  • Status changed from reopened to closed
  • Resolution set to fixed

Doesn't look like it.

comment:12 Changed 11 years ago by mickey@…

  • Component changed from devmand to neod

changing component to neod, devmand category will be removed

Note: See TracTickets for help on using tickets.